When you use the integration of Jurnal.ID with DealPOS, uploading sales & purchase transactions will of course always happen every day. Sometimes in the process of uploading the transaction, several Invoices are not uploaded successfully due to various factors/causes, therefore we try to present some solutions for the problem of failed uploads that sometimes occur.
Table of Content :
I. Deposit to Can't be Empty / not Valid
Causes :
It can happen when you add a new payment method
Solution :
Mapping that payment method in the Outlets menu
II. Transaction Lines Can't be Empty / not Valid
Causes :
It can happen when you add the new payment method.
Solution :
Add new a new tax.
III. Custom ID Attribute had Already Been Used
Causes :
It's can happen when you are trying to upload an Invoice with the same invoice number or re-upload the invoice that has been uploaded.
Solution :
If the invoice code is duplicated due to re-upload, you can ignore it. If indeed the transaction is different but the invoice code is the same, you can change the transaction code & re-upload the invoice.
IV. Transaction Lines Attributes not Available
Causes :
The product on that transaction doesn't exist in Jurnal ID.
Solution :
Try to upload the product in the Products menu at Jurnal x DealPOS
Note : If there's a product want to upload doesn't appear on the SKU not in the journal, the most likely case is because the SKU variant code has not been filled in.
You might also like to read these articles below :
If you are trying to Synchronize some Products that do not exist before in POS, you can check this article Synchronize Products
In case your Tax isn't Synchronized yet, you can access it through the article Sync Tax between DealPOS and Jurnal ID
To upload purhase invoice to Jurnal ID : Upload Purchase Invoice to Jurnal ID